Juri Strumpflohner:

Due to this misalignment of the router package’s version, the team decided to go straight for Angular v4. In this way again, all the core packages are aligned which will be easier to maintain and help avoid confusion in the future.

So, due to one sub-package that got a little out of control, the entire Angular project jumped to v4. This news is literally 10 months old but it’s hilarious to me, seeing it for the first time. I’ve been out of the Angular loop I guess. Bless them.