I’ve udated my one and only public WordPress plugin to be compatible with PHP 7. From the release notes from today’s update:

PHP 4 style constructors (methods that have the same name as the class they are defined in) are deprecated in PHP 7, and this update fixes the warning about this that you get when you’ve set define('WP_DEBUG', true); in your wp-config.php file.

This plugin is used on 3,000 active installs. That’s not a ton, but it’s enough that it’s a privilege to maintain. It solves a true pain point for folks.